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Introduction
The MicroMod Machine Learning Carrier Board combines some of the features of our SparkFun Edge Board and
SparkFun Artemis boards, but allows you the freedom to explore with any processor in the MicroMod lineup
without the need for a central computer or web connection. Voice recognition, always-on voice commands,
gesture, or image recognition are possible with TensorFlow applications. An on board accelerometer and Qwiic
ports allow you even more flexibility.

Let's dive in, get a good look at what's available to us, and go over a few quick examples!

SparkFun MicroMod Machine Learning Carrier Board
 DEV-16400
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Required Materials

IN addition to your Machine Learning carrier board, you'll need a processor board to get started. Here we use the
Artemis Processor Board, but there are a number of others you can choose from.

You'll also need a USB-C cable to connect the Carrier to your computer and if you want to add some Qwiic
breakouts to your MicroMod project you'll want at least one Qwiic cable to connect it all together. Below are some
options for both of those cables:

SparkFun MicroMod Artemis Processor
 DEV-16401

SparkFun MicroMod SAMD51 Processor
 DEV-16791

SparkFun Qwiic Cable Kit
 KIT-15081

Reversible USB A to C Cable - 2m
 CAB-15424

https://www.sparkfun.com/products/16401
https://learn.sparkfun.com/static/bubbles/
https://www.sparkfun.com/products/16401
https://www.sparkfun.com/products/16791
https://learn.sparkfun.com/static/bubbles/
https://www.sparkfun.com/products/16791
https://www.sparkfun.com/products/15081
https://learn.sparkfun.com/static/bubbles/
https://www.sparkfun.com/products/15081
https://www.sparkfun.com/products/15424
https://learn.sparkfun.com/static/bubbles/
https://www.sparkfun.com/products/15424


Along with a processor and the pertinent cables and accessories, if you want to take full advantage of the features
of the Machine Learning Carrier Board, you will need a microSD card:

Suggested Reading

The SparkFun MicroMod ecosystem is a unique way to allow users to customize their project to their needs. Do
you want to send your weather data via a wireless signal (eg. Bluetooth or WiFi)? There's a MicroMod processor
for that. Looking to instead maximize efficiency and processing power? You guessed it, there's a MicroMod
processor for that.

MicroMod Ecosystem

We also recommend taking a look through the following tutorials if you are not familiar with the concepts covered
in them:

USB 3.1 Cable A to C - 3 Foot
 CAB-14743

microSD Card - 16GB (Class 10)
 COM-15051
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Hardware Overview

Common Components

Most SparkFun MicroMod Carriers will have some common components and all MicroMod Carriers will have the
keyed M.2 MicroMod Connector to plug your processor into. The photo and list below outline some of the
components you can expect on most SparkFun MicroMod Carriers.

M.2 MicroMod Connector - This special keyed M.2 connector lets you install your MicroMod Processor of
choice on your Machine Learning Carrier Board.
USB-C Connector - Connect to your computer to program your Processor and also can provide power to
your MicroMod system.
3.3V Regulator - Provides a regulated 3.3V and sources up to 1A.
Qwiic Connector - The standard Qwiic connector so you can add other Qwiic devices to your MicroMod
system.
Boot/Reset Buttons - Push buttons to enter Boot Mode on Processor boards and to Reset your MicroMod
circuit.
microSD Slot - Insert a microSD card for reading and writing data.

Getting Started with MicroMod
Dive into the world of MicroMod - a compact interface
to connect a microcontroller to various peripherals via
the M.2 Connector!

MicroMod Artemis Processor Board Hookup
Guide
Get started with the Artemis MicroMod Processor
Board in this tutorial!

Designing with MicroMod
This tutorial will walk you through the specs of the
MicroMod processor and carrier board as well as the
basics of incorporating the MicroMod form factor into
your own PCB designs!

New!
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Machine Learning MicroMod Carrier Board Specific Components

Digital MEMS Microphones

What's better than ONE microphone? TWO!

Microphone 1 supports a PDM interface and is enabled by default. To disable this mic, cut the EN1 jumper.
For more information on this microphone, refer to the datasheet here.
Microphone 2 supports an I2S interface and is disabled by default. To enable EN2, solder the jumper pads
to close the circuit. For more information on this microphone, refer to the datasheet here.

GPIO

Along the sides of the Machine Learning Carrier Board, we've broken out dedicated PTHs for UART, digital,
analog, pulse width modulation, and SPI. You may also notice that we've included a ground rail on the right side of
the board.
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I C Specific GPIO

Additionally, we've broken out the I C SDA and SCL lines, with 3V3 and GND to complete your I C functionality.
These are primary I C pins - they are connected to the Qwiic connector.

Accelerometer

The LIS2DH12 is an ultra-low-power, high performance, three-axis linear accelerometer belonging to the “femto”
family with digital I C/SPI serial interface standard output. If you need more detail on this little guy, refer to the
Datasheet here.
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Camera Connector

With this 24 pin connector, you can add image recognition to your machine learning board by popping in the Himax
CMOS Imaging Camera.

JTAG

An unpopulated JTAG footprint is available for more advanced users who need breakpoint level debugging. We
recommend checking out our JTAG section for the compatible male header and a compatible JTAG programmer
and debugger.

https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/16400-SparkFun_MicroMod_Machine_Learning_Carrier_Board-Accel.jpg
https://www.sparkfun.com/products/15570
https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/16400-SparkFun_MicroMod_Machine_Learning_Carrier_Board-CameraConnector.jpg
https://www.sparkfun.com/categories/tags/jtag


RTC Battery

We've included a 3V Lithium Rechargeable Battery as a backup power source.

Jumpers
VE Jumper

VIN and 3V3 Jumpers
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Cutting these jumpers will disable the VIN and 3V3 LEDs on the front of the board.

I C Jumper

If you are daisy-chaining multiple Qwiic devices, you will want to cut this jumper; if multiple sensors are connected
to the bus with the pull-up resistors enabled, the parallel equivalent resistance could create too strong of a pull-up
for the bus to operate correctly. As a general rule of thumb, disable all but one pair of pull-up resistors if multiple
devices are connected to the bus. To disable the pull up resistors, use an X-acto knife to cut the joint between the
highlighted jumper pads.

RESET PTH

Need an external reset button? These PTH allow you to tie in to the reset functionality.
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Machine Learning MicroMod Carrier Pin Functionality

Note: You may not recognize the COPI/CIPO labels for SPI pins. SparkFun is working to move away from
using MISO/MOSI to describe signals between the controller and the peripheral. Check out this page for
more on our reasoning behind this change.

AUDIO UART GPIO/BUS I C SDIO SPI0 Dedicated

Name Bottom Pin    Top   
Pin

Name

(Not Connected) 75 GND

74 73 CAMERA_D5

RTC_3V 72 71 CAMERA_D6

70 69 CAMERA_D7

66 65 CAMERA_HSYNC

64 63 CAMERA_VSYNC

62 61 SPI_CIPO

60 59 SPI_COPI

MACHINE LEARNING CARRIER PINOUT TABLE

MICROMOD GENERAL PINOUT TABLE

MICROMOD GENERAL PIN DESCRIPTIONS
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https://www.sparkfun.com/spi_signal_names


58 57 SPI_SCK

CAMERA_MCLK 56 55 SPI_CS

CAMERA_PCLK I2S_SD 54 53

PDM_DAT I2S_WS 52 51

PDM_CLK I2S_SCK 50 49 BATT_VIN/3

CAMERA_D4 48 47 PWM1 CAM_VDD

CAMERA_D3 46 45

CAMERA_D2 44 43

CAMERA_D1 42 41

CAMERA_D0 40 39

A1 38 37

A0 34 33

PWM0 32 31

24 23 SWDIO

22 21 SWDCK

20 19 RX1

CAMERA_TRIG D1 18 17 TX1

CAMERA_INT 16 15

I C_SCL 14 13

I C_SDA 12 11 BOOT

HEADER_CS D0 10 9 VIN

8 7 GND

RESET 6 5 USB_D-

3.3V_EN 4 3 USB_D+

3.3V 2 1 GND

2

2



Board Dimensions

The Machine learning Carrier Board measures 2.3 inches by 2.05 inches.

Hardware Hookup
To get started with the Machine Learning Carrier Board, you'll need a compatible processor board. Here we are
using the MicroMod Artemis Processor Board.

Align the top key of the MicroMod Artemis Processor Board to the screw terminal of the Machine Learning Carrier
Board and angle the board into the socket. Insert the board at an angle into the M.2 connector.

Note: There is no way to insert the processor backward since the key prevents it from mating with the M.2
connector and as an extra safeguard to prevent inserting a processor that matches the key, the mounting
screw is offset so you will not be able to secure an improperly connected processor board.

The Processor Board will stick up at an angle, as seen here:

https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/MachineLearningCB_Dimensions.png
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Once the board in the socket, gently hold the MicroMod Processor Board down and tighten the screw with a
Phillip's head.

Once the board is secure, your assembled MicroMod system should look similar to the image below!

Connecting Everything Up

With your processor inserted and secured it's time to connect your carrier board to your computer using the USB-C
connector on the Carrier. Depending on which carrier you choose and which drivers you already have installed,
you may need to install drivers.

 Note: Make sure that for whatever processor board you choose, you have the correct board definitions
installed.  

For this particular tutorial, we are using the MicroMod Artemis Processor Board. Board definitions for this
processor board can be found in the Software Setup and Programming section of the MicroMod Artemis
Processor Board Hookup Guide.  

If you are using a different processor board, go to our MicroMod Processor Boards landing page, find your
processor board, and head on over to that tutorial for help installing your board definition.

Example 1: Blink

Note: This example assumes you are using the latest version of the Arduino IDE on your desktop. If this is
your first time using Arduino, please review our tutorial on installing the Arduino IDE. If you have not
previously installed an Arduino library, please check out our installation guide.


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To get started uploading code and working with your Machine Learning Carrier Board, make sure you have the
MicroMod Artemis board definition selected under your Tools > Board menu (or whatever processor you've
chosen to use).

Having a hard time seeing? Click the image for a closer look.

Then select your serial port under the Tools > Port menu.

Loading Blink

Let's start with something basic - let's blink an LED. Go to File->Examples->01.Basics->Blink.

Having a hard time seeing? Click the image for a closer look.

With everything setup correctly, upload the code! Once the code finishes transferring, you should see the STAT
LED on the Artemis Processor Board begin to blink!

If the blue LED remains off, it's probably still sitting in the bootloader. After uploading a sketch, you may need
to tap the reset button to get your MicroMod Artemis to run the sketch.

Look at all the blinks!

https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/BoardDropDown.png
https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/portSelect.png
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Example 2: Accelerometer

Note: This example assumes you are using the latest version of the Arduino IDE on your desktop. If this is
your first time using Arduino, please review our tutorial on installing the Arduino IDE. If you have not
previously installed an Arduino library, please check out our installation guide.

SparkFun has written a library to work with the LIS2DH12 Accelerometer that's included on this board. You can
obtain this library through the Arduino Library Manager by searching for "LIS2DH12". Find the one written by
SparkFun Electronics and install the latest version. If you prefer downloading libraries manually, you can grab
them from the GitHub Repository. We've linked the datasheet for the accelerometer in the Resources and Going
Further section, but if you'd like it handy, you can also refer to it here.

SPARKFUN LIS2DH12 ARDUINO LIBRARY GITHUB

With your library installed, navigate to the examples located under File->Examples->SparkFun LIS2DH12
Arduino Library. Let's load up Example1_BasicReadings to get you started.

Having a hard time seeing? Click the image for a closer look.
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Making sure you have the correct board and port selected, go ahead and upload your code. Once the code
finishes transferring, open the serial monitor and set the baud rate to 115200. You should see x y and z locations
flying by, telling you the directions the accelerometer is reading!

Having a hard time seeing? Click the image for a closer look.

Troubleshooting

 Need help? 

If your product is not working as you expected or you need technical assistance or information, head on over
to the SparkFun Technical Assistance page for some initial troubleshooting.  

If you don't find what you need there, the SparkFun Forums are a great place to find and ask for help. If this
is your first visit, you'll need to create a Forum Account to search product forums and post questions.  

SparkFun MicroMod Forums

Resources and Going Further
Want more information on the SparkFun Machine Learning Carrier Board? Check out these links!

Schematic (PDF)
Eagle Files (ZIP)
GitHub Hardware Repo
Accelerometer Datasheet
Default PDM Microphone Datasheet
Microphone 2 I2S Datasheet

MicroMod Documentation:

Getting Started with MicroMod
Designing with MicroMod
MicroMod Info Page
MicroMod Forums

Looking for some project inspiration using your Machine Learning Carrier Board? The tutorials below can help you
get started!


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MicroMod ESP32 Processor Board Hookup
Guide
A short Hookup Guide to get started with the SparkFun
MicroMod ESP32 Processor Board

MicroMod All The Pins (ATP) Carrier Board
Access All The Pins (ATP) of the MicroMod Processor
Board with the Carrier Board!

SparkFun MicroMod Input and Display Carrier
Board Hookup Guide
A short Hookup Guide to get started with the SparkFun
MicroMod Input and Display Carrier Board

New!

MicroMod Data Logging Carrier Board Hookup
Guide
Get started with some customizable MicroMod data
logging with the Data Logging Carrier Board.

New!
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